Wanted: SavvyCAN HowTo

#1

Who here has had success running SavvyCAN? I’ve got M2RET (https://github.com/collin80/M2RET) running on my M2 (I see messages printed over serial), but I’m not seeing any CAN frames show up.

If you’ve got it running, which version of SavvyCAN and M2RET are you running? Once I’ve got it working I’d be happy to put up a quick howto for others who’ll be running into the same thing as they get their devices.

#2

I downloaded the latest from Collins repositories. His readme states on it not to use the M2 libraries but his. I have gotten as far as connecting to the M2 unit but haven’t tried in car yet. If you are using the libraries from the M2 repository that might be the reason?

Will try it in car in a couple hours.

#3

I followed his directions and used the libraries from the M2ret readme. It compiles, runs, and connects in savvycan, but I don’t see any traffic in savvycan when the M2 is connected to my odb2 port with the car started.

I’m guessing that I’m missing a setting or small step. Just looking for someone who has it working who can help before I resort to hardcore debugging.

#4

Looks like Collin did a walk through of SavvyCAN here:

https://www.youtube.com/user/CKidder80

but this was before we released M2, so a more in-depth set of instructions would be great!

I’ve got M2RET and SavvyCAN up and running with my test bench setup (2006 Ford Fusion ECU). I’m using verison 157 downloaded from here: http://www.savvycan.com/. Here is a screenshot:

#5

Thanks for that screenshot, that answers a lot of my questions.

Unfortunately I’m still not seeing any CAN traffic in SavvyCAN. Which revision of M2RET are you using? I’m using https://github.com/collin80/M2RET/commit/f56b2f3bcc029ce55e72a54f8043dc1e40f5ea31, the latest in master.

Is there anything I need to do to start capturing frames on either the M2 or in SavvyCAN or is it supposed to just start capturing as soon as I connect?

#6

Yep, It should just start dumping CAN data once you are connected. I’d start with just CAN0 and leave CAN1 disabled - select the port and hit update - it should just start dumping data. I’ll get in touch with Collin to see if he can join the conversation.

#7

Collin just responded a couple hours ago in the OpenGarage slack that he will be trying to get caught up on the M2 stuff as soon as possible. He has been tied up RE Tesla S vehicles so has been splitting time. Hopefully this means in the next week or so stuff will start clicking.

I will see if it works in my vehicle with the latest version running.

Using Windows 10 on my laptop.

#8

My vehicle worked fine with mine with no issues. Selected just Can0 at 500000 baud and connected. Started displaying data with no issues.

Used the code from Collins repositories as of 4/16.

Also used latest Arduino IDE and used the method in the Macchina video to install the Macchina pack.

For comparison I loaded just the SavvyCan on my laptop and nothing else and it ran fine. I only have the IDE on my desktop at this time.

Rodney

#9

I pulled down the latest as of 4/18 and everything is working now. Collin’s latest commit had a few bug fixes. I’m not sure if those are what got things working or just starting fresh did it, but I’m good now.

Thanks everyone for the help. Now to decode some CAN frames!

split this topic #10

5 posts were split to a new topic: SavvyCAN “overwrite” issues

split this topic #15

6 posts were split to a new topic: SavvyCAN with a 2003 Toyota Corolla?

split this topic #21

7 posts were split to a new topic: SavvyCAN always shows status as “Not Connected”

#28

Yeah, sorry, the documentation is lacking. The problem open source developers (well, any developers) face is that everything takes time. I can either fix bugs and add features or document the features that already exist. In a larger company you have some people who code and some people who write documentation so that makes it easier.

But, recently I did have someone who has used the program for months but yet didn’t know about a pretty basic feature. That kind of clued me in that there are only about 2, maybe 3 people who know about most of the features in SavvyCAN. That’s no good. I’ll have to try to prioritize more videos to explain things. I once got into writing help file documentation too.

#29

No problem. We should appreciate that you have been improving the SavvyCan continuously. Now, I am watching some of your old videos in the youtube (https://www.youtube.com/watch?v=JPcrpQwnNJc).

I am also wondering if it is possible to record GPS signal connected through the 26 pin header while using M2RET. Now, I can capture frames using M2RET and view using SavvyCan.

#30

Well, I suppose it’d be possible to capture GPS input but the firmware isn’t coded to read it so you’d have to add that. It doesn’t seem to be a super common request so it couldn’t be high up on my list of things to add at this point.

split this topic #31

6 posts were split to a new topic: Issue with CAN logging a 2007 Volvo c70

split this topic #37

A post was split to a new topic: SavvyCAN/M2RET not working with my bench

split this topic #38

3 posts were split to a new topic: Possible issue using M2RET with benches but not cars

#43

how do you get m2 and savvycan working? do i need to install anything onto the m2? and if i do how?

#44

Please go to http://docs.macchina.cc/ and follow the docs…