Unable to see any CAN traffic with M2 on Volkswagen Vento and Chevy Beat

Hi All,

I am newbie to automotive cyber security and after becoming conversant with using canutils and SavvyCAN on ICS simulator , i wanted to try the same techniques on my cars (Volkswagen Vento -2011 model and Chevy Beat : 2012 model).

I followed the instructions on this web page (https://docs.macchina.cc/projects/use-m2-with-savvycan) exactly and everything worked like a charm (e.g. flashing M2 and replaying some CAN packets through it before connecting it to the car) . Used M2RET and SavvyCAN V199 on windows 10 Home edition.

However, i am unable to sniff/capture any CAN traffic when i connect the M2 to OBD on any of my two cars, despite the fact that SavvyCAN shows status as “connected”.

ELM327 OBD adapters work fine with their diagnostic apps on both cars though.

Can anyone please advise as to what i could be doing wrong here. Please do let me know if you need any more information that could help with resolving my query.

Many Thanks in advance of any help you could provide.
Rick.

First of all we need to know what year your car is. The feds Mandated all US cars to be equipped with CANBUS about 2008 and some did start rolling out CANBUS before that. Prior to that your car likely has a different protocol which is not compatible at this time with SavvyCan or canutils.

Hi ,I have tried on both my cars now : Volkswagen Vento 2011 and Chevy Beat - 2012. Used M2RET and SavvyCAN v199 on windows 10 home edition.

Also, ELM327 OBD adapters work fine with their diagnostic apps on both cars though.

Some cars will not talk on the Diagnostic port without prompting. I would suggest you get a Y adapter and plug the M2 into one port and the ELM into the other port. Get the ELM talking to the car and then try to get your M2 to view it.

Once you have that working try it without the ELM and see if it still works. If it doesn’t then you probably need a request command sent to get the information to the Diagnostic port. Your ELM software has this request command being sent and it is running it. You need to identify that command if your M2 works with it in place but not when it isn’t. SavvyCan supports including these “wake” commands.