M2/SavvyCan - seeing lots of traffic, sent frames seem to be ignored

Im not sure how to begin on this one because im still very much a novice with this but im having issues with Frame Transmission (lack of anything happening thereafter).

I have the M2 flashed and talking to SavvyCan. Once everything is plugged in (via OBD2, tried directly and through a 3 way cable) configured for the right COM port I can see lots and lots of traffic flowing. However when I am using the Frame Sender, I am not seeing any expected behavior. It comes up in the data capture as a Transmission Tx, but thats it.

I am still working on my little project described here and have gotten lots of very useful feedback in this reddit thread in case anyone is curious.

The above use case was to get data out of the car, and i guess is more complex so I wanted to try something simpler ive been able to isolate the frame that tells the BCM/ECM that the door is open, by triggering the door switch back and forth. So i tried sending the frame with the opposite message (that it is closed), i believe the frame was something like
ID: 0x60D, length 8 with a data payload of 0x00 0x08 0x00 0x00 0x00 0x00 0x00 0x00 (every 1ms)
however my request is seemingly ignored by the fact that the dash-light still says its open (because it is).

So i cant figure out if its a M2 issue, a savvy can issue, a me issue ,or a car issue?
I haven’t tried the Scripting Interface yet.

TLDR:
M2/SavvyCan is setup, see lots of traffic
Using frame sender, frames are sent (Tx)
Nothing seems to happen
Something should happen

Wanted to give an update to anyone following or experiencing similar things.

I ended up testing this with the Scripting Interface that uses Javascript and it works !
So theres something about the Custom Frame Sender/Replay that isnt working for me but again the Scripting Interface does indeed do the trick !

Implementing a Finite State Machine is a bit tricky though so i still need to improve the code in that regard.

1 Like