M2 - No LED's work

Hi all,

Received my M2 a couple days ago. So far I have not been able to get past the blink script while following the guide. I’ve individually tested each of the LED variables, DS6, RGB_GREEN, etc. None of them light up.

Has anyone else had this issue? This is not my first experience with arduino. Also, I am terrible at soldering and so I really hope to avoid having to do so…ruined a few boards in my day due to my shaky hands.

Any advice anyone can give me will be greatly appreciated.


Sorry you’re having issues. Don’t get out the soldering iron just yet! :slight_smile: We’re going to need some more information to be able to help out.

You said you went through this guide? http://docs.macchina.cc/m2/getting-started/arduino.html

So, after selecting “Macchina M2” from board manager and uploading the “Blink” example sketch, nothing happens?

Well, following this guide Can’t get it to work on Arduino worked. Nothing was working prior to following that, although I was able to connect it to ACM0 and select M2 as the board with no issues (code also compiled and ran 100%). I’ll keep the reset trick in mind going forward.

Right on! Glad you got it working. We’ll see if we can update the main guide page with this tip for the next person. Now go hack some cars!

If the example blink script works, but your own ‘turn on a LED’ script does not, check that you are setting the pin LOW to turn the led on and HIGH to turn it off.

I’m reviving this old thread as I’m having the same exact issue. I received my M2 a few weeks ago and have been unable to get to function. I’ve tried everything suggested in this thread and other similar threads. I have followed the install instructions to the T. I’ve uninstalled and reinstalled the IDE several times, I’ve deleted the folder Arduino15, manually selected the drivers, selected the appropriate com ports corresponding to the USB cable, loaded the “Blink sketch” to verify and nothing works. The M2 is detected when plugged in or when the “Reset” button is pressed, but no LEDS illuminate. I’ve tried to install the M2 on 2 different Windows 10 laptops and the same result is present on both. Just to clarify, prior to the M2 I’ve installed and used the Arduino Due board with CANbus shield and have never had this issue occur during installation. At this point I’m leaning towards a problem the M2 itself. If any of the developers can help with this it would be greatly appreciated


Try different USB cables on different ports. When I have had issues like that it has always been the USB cable.

I have also tried several USB cables, many of them extra thick with a snug fit into the micro usb port. I bought another cable just to check and it also did not work…

Hi VK,

If you are still having problems please reach out to us at info@macchina.cc so we can get this figured out.

I just figured out what the issue was, upon installing all software and drivers, I was trying to initialize the m2 by loading an example sketch. I was actually hitting the “verify” button not the “upload” button. Once I uploaded the sketch the board LED began to blink. Once it started blinking the com port number changed on the Arduino IDE and in the device manager. So everything is working properly!