Having weird issues with my M2

#1

Hey everyone, I just bought a M2 Under The Hood model and I tried messing around with it and my car but I ran into a weird issue. My vehicle has 2 can busses: HSCAN and MSCAN. I can connect to the HSCAN, read, and write without any issues, but the moment I connect to the MSCAN, my whole car goes crazy with warning lights everywhere. All of the data sent on that bus gets delayed ( I can press my high beam switch and itll trigger 5 seconds later) and half of the things on it stop working altogether. If I change the baud rate to not the standard MSCAN baud, it seems to reset the car back to normal. I am using the latest M2 with M2RET and SavvyCAN under windows10. Everything is up to date on the latest version. I have tried using other tools like a cannable or the teensyRET with no issues at all. I also swapped the two canbusses going to the M2 and there was no change. I measured the resistance between the two canbus lines on the m2 and both channels return the same rating. Hooking into the OBD port with a ScantoolMX shows that all of the devices on the MSCAN bus reported an error with the bus being unreachable(paraphrasing). Has anyone else encountered this before? If so, how did you solve it?

#2

Make sure you are connecting to the right wires…

Sounds like you are connecting to the wrong wires to me.

#3

There is only a few ways I’ve had this happen to myself. But I only recall the first 2 causing the bus to crash, I don’t recall hooking up wires incorrectly and crashing the BUS although I’m sure it can do that.

Incorrect baud rate
flooding the BUS with massive amounts of messages
incorrect wiring

#4

Everything was connected properly and configured correctly. I called it a night there and went to bed. Tried it the next day after giving my car, laptop, and the m2 a break and it worked perfectly. Haven’t seen the issue since.

One thing I noticed tho is that savvycan won’t disable the can0 using the connection manager. I have to close savvycan, open a terminal and manually type in “CAN0EN=0”. Seems to work fine on the CAN1