A0 Can not open serial port. Error opening serial port '/dev/ttyUSB0'. (Port busy)

I just received an A0 from sparkfun. When I try to access the serial console I get the following message, ‘Error opening serial port ‘/dev/ttyUSB0’. (Port busy)’.

I’ve tried multiple usb cables. I’ve even reinstalled arduino and Arduino-Esp32. I even went so far as to try and reflash with the production zip. That also errored out because it was unable to open the serial port. What are my options?

I’m up and running with my A0.
what are you trying to do and what is giving the error message?
you can get the ESP32RET_ino off github and not go through the zip file

I think the latest Arduino ide is flakey. I have one laptop that will load sketches to the A0 no problem but another I have to hold the EN pin low to load sketches. also the latest ide had a lot of trouble loading sketches to my esp32 lolin C3 mini boards, the ide kept on renaming the boards to other C3 brands and failing

I’m trying to access the settings via the serial port. I am using the latest Arduino version before the release of arduino ide version 2, I’m pretty sure the version I tried using to access the serial port was 1.8.19. I also tried uploading the latest ESP32RET.ino from GitHub. I am able to compile it without issues but that also errors out with a busy port error when it comes time to upload it.

Sparkfun is exchanging the A0. Hopefully I don’t have issues when the other one arrives. Thanks for your help.

I’m using 2.0.3
all in all I like the improvements. turn off auto save though unless you like random lag when it saves and your curser changes position and characters are dropped mid typing.
I think the board auto detect implementation was a mistake, seems to be causing most of the flakiness.
did you try a different computer?


do post back when you get the replacement

your probably running into the same thing that I did. its the lack of a boot button.
ya need to hold pin 25 low on when you load a program till you have the right something in the ide to load without holding the boot pin low.
they should have used that instead of giving us a useless reset button. (not like ya can’t unplug it and plug it back in.

initially I would pop the case and use a pin touching the solder pad and leaned against the shield to pull it low, then I put a button after too many time popping the case apart.

the some bit of code or library that lets you bypass holding the boot pin low is on my secondary laptop which is too big and clunky to have on my lap in the car (mx5), but for the life of me I can’t find what’s different.

ya may reach out to customer support at macchina see if someone will tell you how to not need the non existent boot button.

or take some time and look up how to load sketches to an esp32 without using the boot button. (it was quicker for me to drill the hole and add the micro button next to the reset button)

post up what you find.

I finally got my replacement A0 from sparkfun. I’m still having issues accessing the settings through the serial port. I’m getting the same error message as before, ‘Error opening serial port ‘/dev/ttyUSB0’. (Port busy)’. For shits and giggles I connected my laptops wifi to the A0 and I was able to access the settings by telnetting into the A0 using Putty. I haven’t tried uploading any code to this replacement A0. I have a feeling that the current info is lacking specifics. I appreciate everybody’s help. I got lots of reading to do. I’ll be sure to post if I have any eureka moments.

I’m right there just ahead of you. I had a eureka moment today. I’ve had one laptop that required the boot pin held low to download sketches and another laptop that load sketches just fine automatically. I just loaded the new release ide 2.10 and now the laptop requiring the boot pin held low does not.

when you plug in the A0 what does the port show in windows device manager?

see my comments below the github A0 can vehicle data example sketch listed in the A0 projects.

I do not use Windows so I dont have windows device manager. I’m running kubuntu 22.04. lsusb lists it as: Bus 001 Device 008: ID 10c4:ea60 Silicon Labs CP210x UART Bridge. and dmesg shows:
sudo dmesg | tail
[13447.203043] cp210x ttyUSB0: cp210x converter now disconnected from ttyUSB0
[13447.203386] cp210x 1-2:1.0: device disconnected
[15094.927245] usb 1-2: new full-speed USB device number 8 using xhci_hcd
[15095.077508] usb 1-2: New USB device found, idVendor=10c4, idProduct=ea60, bcdDevice= 1.00
[15095.077524] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[15095.077531] usb 1-2: Product: CP2104 USB to UART Bridge Controller
[15095.077537] usb 1-2: Manufacturer: Silicon Labs
[15095.077542] usb 1-2: SerialNumber: 02728D31
[15095.082919] cp210x 1-2:1.0: cp210x converter detected
[15095.084614] usb 1-2: cp210x converter now attached to ttyUSB0

have you worked with ESP32 boards before?
if so have you had any trouble?
if not do you have the silicon labs CP2102 usb to uart driver installed?

what version ide are you using?

Sorry for not replying. I had to put it away for a bit to gather my senses and patience. To answer your questions, I have programmed and esp32 before and I’m using the last release of the first version of the Arduino ide. I think it’s 1.8.13.

Anyways, I plugged it into the USB yesterday and was able to access the menu using the Arduino serial monitor. I reinstalled my laptops operating system between starting this thread and now so my issues with connecting to the A0 through serial might have been caused by something to do with that installation.