OBDII Scanner Sketch


#21

The 2005 Grand Caravan probably won’t work as vehicles that old don’t tend to use CAN on the OBDII port. The three 2013 vehicles should have worked. I find it interesting that one of the cars went to 125000 for the speed. That’s pretty low but makes sense, it’s probably a low speed body control system. Anyway, it it successfully negotiated auto baud then that’s a good sign. You might try some of the other sketches like M2RET to see if those vehicles are indeed sending traffic. It’s possible that they’re not responding for some unknown reason but it’d be nice to know if things are actually working on the bus or not.


#22

Good news, I’m able to capture frames and save log with M2RET & SavvyCan on the three 2013 cars. And as you predicted, the Grand Caravan 2005 doesn’t work at all.

I tried again the OBD Scanner sketch without success.

May be this can help (although I feel it’s limited to how the serial port behave, and shouldn’t interfere with SD card), I notice after uploading sketch the M2 is recognized as Arduino DUE (COM28) on my laptop, but as soon as I plug the M2 in a car it dissappears and reappears as Bossa Program Port (COM29), and never comes back as Arduino Due and stays stuck as Bossa. (I’m not sure if it adds any useful info).

OBD Scanner sketch should still work but doesn’t.
Thx


#23

Following the limited success I had with SavvyCAN, I tried its UDS scanner (to my understanding it does approximately the same thing as the OBD Scanner sketch) but it failed by falling in a endless loop finding nothing (I had to kill the SavvyCAN program to get out).

That just adds to my misunderstanding and confusion.


#24

Actually I made dozens of CAN Frame captures and playback of discrete events (door lock, window up/down…) using SavvyCAN as describes on Chapter 5 in the Car Hacker’s Handbook.

None of the playback works (it does nothing except flashing various lights in the dash).

So I wonder if all frames captured would be corrupted in some way ? (something wrong with my M2 ?) That would be a common cause to all: OBD Scanner sketch fail, SavvyCAN UDS Scan fail, and playback fail.

Can someone bring some light on this ?


#25

The UDS scanner shouldn’t go into an endless loop and crash the program. That seems a bit odd. Perhaps I’ll have to go test that again. I’ve used it lots of times myself and haven’t had it freeze.

You are getting weird results. But, if various lights on the dash flash then something must be happening. So I have to assume it is sending something. Perhaps you’re right and it might not be sending the proper things. Unfortunately the only way to verify what is being sent is to have a second device also hooked up and monitoring to see what that second device says.


#26

I watched again your YouTube UDS scanner demo to realize I was doing it wrong.
Now SavvyCAN goes thru but it doesn’t find anything (on the Subaru BRZ, didn’t test the other).
See UDS export file content below;

UDS Scan Log:

0x07E0
TESTER_PRESENT
0x00
No Reply

0x07E1
TESTER_PRESENT
0x00
No Reply

… All the same up to 0x07EF.

(I know the OBD2 port on the car is good as it works fine with ELM327 Reader (Bluetooth, cheap chinese clone) with various app such as; Torque Lite…)

I don’t have a second Macchina M2, but I have a Can Bus Shield for Arduino Uno that I can use to monitor what the Macchina is doing.
Is there a sketch for the Uno that can help me troubleshoot the M2 ?
(I tried some stuff but everything failed…)


#28

I am hoping thay someone can help me with this. I ran the scanner on my car and returned ERR! For pid 1-128, i did recoece the vin and 129-160, however i got an extremely long string of an unknown character for ID 137, I am attempting to get it to send me RPM info for a shift light